Results 1 to 3 of 3

Thread: Ford C6 help

  1. #1
    Might as well be part of the furniture.
    Join Date
    Jan 2014
    Location
    Outside the M25
    Posts
    896

    Ford C6 help

    My C6 played up this morning.
    I know nothing about autos except they are a box of Voodoo.
    Reverse is strong, 1st and 2nd seem OK I have no forward motion when in the D position.
    Oil , filter and pan were changed a few weeks ago.
    When the original pan was drained the fluid came out clear red.
    I think the original fluid was ATF.
    A new deeper pan was fitted with new filter and new fluid. Was advised that ATQ was OK to use instead of ATF.
    The modulator was swopped out from a pink band to a black band.
    Filled up seemed to work OK.
    Then had to swap pan due to ground clearance problems.
    Noticed fluid looked a little on the brown side.
    Now I have no forward drive in D.
    Any ideas?
    Last edited by fabphil; 13-08-17 at 09:08 PM.

  2. #2
    Might as well be part of the furniture.
    Join Date
    Jun 2013
    Location
    Bucks
    Posts
    2,915
    You may have caught that my buddy owns STA, auto rebuild shop in Aylesbury... www.staautogearbox.co.uk. take a look. Done many race and rod transmission.


    Ok so has it got 1 & 2 in D or just nothing? Underfill normally shows with a slow pick up of reverse, as a first sign. Is the new modulator adjustable and is the kickdown cable connected and adjusted?

    I will talk to my bud tomorrow as he has just done a C6 for an early Mustang. Also is the trans standard? If so might be worth thinking about some upgrade parts with the new BB going in.

    If I remember, reverse is on a band of its own, so 3rd and reverse is not the same clutch. Could be the direct clutch is worn out or the seals have run out of life.

    Give me a call tomorrow on 01296 481145
    gerry
    Last edited by fad15; 14-08-17 at 05:51 AM.

  3. #3
    Might as well be part of the furniture.
    Join Date
    Jan 2014
    Location
    Outside the M25
    Posts
    896
    We have Reverse, nothing in Drive, then OK in 1st & 2nd position.
    Vac checked at 15, oil level good although there is a little trans oil leaking into the trays under the car.
    Was looking at getting some upgrades to the internals due to the new motor.
    Just didn't need it this soon.
    Was hoping to drive it this summer and pull the box in October

    Don't know much about the trans.
    The paper work that I have would suggest it has a B&M shift kit but don't know which one.
    No kick down cable fitted at present.
    The new modulator is adjustable and has been set to 10.5lbs as per the advise on 460Ford .com.
    Not sure about the length of the modulator pin, its the original one from the original modulator.
    Last edited by fabphil; 14-08-17 at 07:22 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •