Page 27 of 27 FirstFirst ... 17 25 26 27
Results 261 to 266 of 266
  1. #261
    Might as well be part of the furniture.
    Join Date
    Jan 2014
    Location
    Outside the M25
    Posts
    1,398
    Quote Originally Posted by stilltrying View Post
    Is that the screen or just the rubber seal?
    The new screen was cut exactly to the original, I couldn't be bothered to mess around making a new template
    Looks like the original screen didn't fit properly in the first place.
    The rubber was always two pieces, the top and sides are standard S profile the bottom is one I've not seen before, but the S profile wont fit the glass shell at the bottom, so it is what it is.

    I'll try some small adjustments but I don't want to scratch the new paint.

  2. #262
    Might as well be part of the furniture.
    Join Date
    Jan 2014
    Location
    Outside the M25
    Posts
    1,398
    Onward!!!...

    The first results of the blasting and powder coating are in


    Front and rear springs, wheelie bar spreader and springs. The springs are the original greasy blue ones the car came with.
    They were blasted with an alumimium silicate medium to remove the existing coating. Each spring took about 45 minutes to strip.
    Once the coating was applied they were baked for 20mins at 180 degrees in my home made oven and allowed to cool down. For a first go I'm happy.

    Springs in place.


    I will be stripping and satin black powder coating the front A-arms, hubs, and steering rack parts etc over the winter.



    Just ordered some satin black powder for various brackets and spacers, watch this space.
    Last edited by fabphil; 28-06-22 at 11:25 AM.

  3. #263
    Might as well be part of the furniture.
    Join Date
    Jun 2013
    Location
    welwyn
    Posts
    2,355
    Looking good from here will have to see them in the flesh at the Nationals.

    One point though, and nothing to do with your coating, are the front springs close to getting coil bound? the rears look fine and dandy the fronts in that photo look a bit close.

  4. #264
    Might as well be part of the furniture.
    Join Date
    Jan 2014
    Location
    Outside the M25
    Posts
    1,398
    Quote Originally Posted by stilltrying View Post
    Looking good from here will have to see them in the flesh at the Nationals.

    One point though, and nothing to do with your coating, are the front springs close to getting coil bound? the rears look fine and dandy the fronts in that photo look a bit close.
    Just been out an had a look.
    The front springs are the originals the car was built with, 9" 600lbs each side. Full engine weight is around 700lbs!
    As they sit now they measure 7.5".
    I can stand on the chassis and bounce up and down and they just about move.

    Tried turning her over last night and couldn't get any oil pressure.
    Earthed the oil gauge wire and the needle moved across so that's OK, now got to look into that problem.
    Also have a weird earth fault on the fuel pump and fan switches.
    When the ignition is on and providing 12v all seems to work as expected.
    When the key is removed the fuel pump starts up on its own!!!
    Some where the relay is getting an earth and switching on....out with the torch, volt meter and glasses

  5. #265
    Might as well be part of the furniture.
    Join Date
    Jun 2013
    Location
    welwyn
    Posts
    2,355
    Quote Originally Posted by fabphil View Post
    Just been out an had a look.
    The front springs are the originals the car was built with, 9" 600lbs each side. Full engine weight is around 700lbs!
    As they sit now they measure 7.5".
    I can stand on the chassis and bounce up and down and they just about move.
    Maybe it is the angle the photo is taken, it just looks like the coils are very close together and on full bounce on the road could hit each other, but if not then all good.
    Last edited by stilltrying; 29-06-22 at 10:25 PM.

  6. #266
    Might as well be part of the furniture.
    Join Date
    Jun 2013
    Location
    welwyn
    Posts
    2,355
    Oil pressure sounds like a failed sender unit, capilliary type are more accurate but then you would have to change the gauge as well.

    Hope the other gremlins are easy enough to fix.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •